failed to load config file

I have tried these steps:

  • Access our update URL: http://patch.aruarose.com - OK
  • Access our update file: http://patch.aruarose.com/launcher.xml - OK
  • Try to add "http://patch.aruarose.com" to your exclusions list - no idea how to do this with Windows Defender
  • or right-click on the game launcher and select "Run as administrator" - did it, same error
  • You can also try opening Internet Explorer (which is installed on every computer by default) and ensuring that is able to access the above URLs/files. - OK
I have also added the install folder to exclusions, the INetCache folder was never created because the launcher won't run.
 

sinensis

Developer
Staff member
Developer
That list is actually missing one thing you can try, which I'll add to it now:
What happens when you try to access/download that?

You can create the INetCache folder yourself, or try adding the 'Windows' folder just before it.
 

sinensis

Developer
Staff member
Developer
In your Arua folder, there is a sub-folder called 'Installers'. Try running the files labeled vc_redist_x86_#### in order of year (2008 > 2017).

What operating system are you using? Which version of Internet Explorer is installed?
 
In your Arua folder, there is a sub-folder called 'Installers'. Try running the files labeled vc_redist_x86_#### in order of year (2008 > 2017).

What operating system are you using? Which version of Internet Explorer is installed?
Thanks for the reply.

I'm on Windows 10, running IE 11.

When running the first one, I get this error:

9025

Only 2012 and 2017 worked as "repair", but the others failed.

The config error is still happening.
 

sinensis

Developer
Staff member
Developer
I've not seen that error before, but you can try downloading them direct from Microsoft instead:

https://www.microsoft.com/en-gb/download/details.aspx?id=29
https://www.microsoft.com/en-gb/download/details.aspx?id=5555
https://www.microsoft.com/en-gb/download/details.aspx?id=30679
https://www.microsoft.com/en-gb/download/details.aspx?id=48145
https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads

You're only wanting the x86 version of each download. If it asks you to 'Repair' or 'Modify', then it's already installed so you may not have to do anything.

To be honest, I'm not really sure what else it could be as the error described only occurs in the circumstances in which you've already found. I may tag @Simon™ to see if he has any ideas and he's pretty good at tech help who may have a different idea.
 
I've not seen that error before, but you can try downloading them direct from Microsoft instead:

https://www.microsoft.com/en-gb/download/details.aspx?id=29
https://www.microsoft.com/en-gb/download/details.aspx?id=5555
https://www.microsoft.com/en-gb/download/details.aspx?id=30679
https://www.microsoft.com/en-gb/download/details.aspx?id=48145
https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads

You're only wanting the x86 version of each download. If it asks you to 'Repair' or 'Modify', then it's already installed so you may not have to do anything.

To be honest, I'm not really sure what else it could be as the error described only occurs in the circumstances in which you've already found. I may tag @Simon™ to see if he has any ideas and he's pretty good at tech help who may have a different idea.
This fixed the install issue with the vc installs, but the config error persists.
 
is there any way to do the launcher updates manually? TRose.exe starts ok with no problem, but wants the launcher to be updated.
 
Top