PSA: Windows XP / Vista Announcement

sinensis

Developer
Staff member
Developer
Visitors,

If you currently use Windows 7, 8, or 10, this announcement does not apply to you, so feel free to close the topic and move on.


What are we doing?
We'll soon be releasing an update to our patch client, which delivers updates to your game client and validates the integrity of the game files before you start the game.


What does this mean?
When the update is released, your patch client will update itself, but players who use Windows XP or Windows Vista will not be able to start/run our patch client. Some time after our patch client has been updated, we will be blocking any players who still use Windows XP or Windows Vista from starting our game client and logging in.


How do I know if I will be affected by this update?
This announcement applies to only Windows XP and Windows Vista players. Our usage stats show that this translates to less than 0.5% of our active players since January 2019.


I still use Windows XP or Vista. How can I continue playing?
You must upgrade your Windows to Windows 7, 8, or 10. Our recommendation would be Windows 10, as it appears to perform much more efficiently on older hardware in comparison to Windows 7 and 8.


Why?
Over the years, we've made every attempt to ensure our game client is as backwards compatible with older operating systems as possible to allow all players to play our game - however, this is no longer feasible. Now that Windows XP and Windows Vista usage among our players has dropped below 0.5%, we feel it is now a good time to make the decision to stop supporting the operating systems as a whole. With this decision, it will allow us to look to upgrade our game further, including DirectX.

This is also a reminder that Windows XP has not been supported by Microsoft since 2014, and Windows Vista since 2017, which means that these operating systems no longer receive essential security updates, putting your data at risk. Many other popular programs, like Google Chrome, have also stopped supporting these operating systems.
 
Top